在Hyper-V中运行Linux VM时应该注意什么问题?

2019年11月28日14:51:16
评论

当在Hyper-V环境中使用Red Hat Linux VM的动态内存时,应该注意哪些问题?

微软的Hyper-V公认支持Windows VM,但Hyper-V也支持Linux VM。Hyper-V支持各种Linux发行版的VM,包括CentOS、Red Hat Enterprise Linux(RHEL)、Debian、Oracle、SUSE和Ubuntu。Hyper-V可为大部分Linux版本提供仿真支持,尽管你需要为特殊的驱动版本安装Linux集成服务,以启动Windows服务器平台上的Linux VM。现在,来考虑Hyper-V下运行Linux VM时可能会引起的一些问题。

在Windows Server 2012和Windows Server 2012 R2上使用RHEL 6.5时,有一些问题需要检查。第一个问题涉及到内存映射I/O(MMIO)缺口,其通常提供物理内存空间留给(但很少使用)PCI设备。Windows Server 2012 R2 Hyper-V允许管理员配置两个MMIO缺口来支持虚拟设备配置。配置MMIO缺口的能力是成功部署虚拟设备的重要因素,因此较早的Windows服务器平台需要升级到Windows Server 2012 R2,才能配置并支持RHEL 6.5虚拟设备。

企鹅博客
  • 本文由 发表于 2019年11月28日14:51:16
  • 转载请务必保留本文链接:https://www.qieseo.com/222698.html

发表评论