逆序建立链表

Linux大全评论694 views阅读模式

题目描述

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

输入

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

输出

依次输出单链表所存放的数据。

示例输入

10

11 3 5 27 9 12 43 16 84 22

示例输出

22 84 16 43 12 9 27 5 3 11

#include <iostream>
#include <malloc.h>
using namespace std;
struct biao
{
    int data;
    struct biao *next;
};
void shu_ru(struct biao *head,int n)
{
    for(int i=1; i<=n; i++)
    {
        struct biao *p=(struct biao *)malloc(sizeof(struct biao));
        cin>>p->data;

企鹅博客
  • 本文由 发表于 2019年9月2日 15:25:29
  • 转载请务必保留本文链接:https://www.qieseo.com/179816.html

发表评论