Xen DMA请求IOMMU拒绝服务漏洞

企鹅博客
企鹅博客
企鹅博客
29001
文章
0
评论
2020年9月17日03:04:43 评论 4 views 578字阅读1分55秒

发布日期:2011-08-15
更新日期:2011-08-15

受影响系统:
XenSource Xen 4.x
XenSource Xen 3.x
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 49146
CVE ID: CVE-2011-3131

Xen 是一个开放源代码虚拟机监视器,由剑桥大学开发。

Xen在验证DMA请求的实现上存在拒绝服务漏洞,客户虚拟机中的本地攻击者可利用此漏洞造成拒绝服务。

此漏洞源于Xen没有正确限制到虚拟机直接控制的PCI/PCIE设备的虚假DMA请求,可造成IOMMU故障和较高的CPU负载或死锁。

<*来源:vendor
 
  链接:http://lists.xensource.com/archives/html/xen-devel/2011-06/msg01106.html
        http://xenbits.xen.org/hg/staging/xen-4.1-testing.hg/rev/84e3706df07a
*>

建议:
--------------------------------------------------------------------------------
厂商补丁:

weinxin
欢迎加入中国站长博客之家
本站的所有资源都会上传分享到博客之家,希望大家互相学习交流进步。
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: